Element Count = 0 for volume block

Discussion about meshing issues.

Element Count = 0 for volume block

Postby skusafzai » Mon Dec 02, 2013 5:02 am

Dear All,

I am constructing a model for SPECFEM3D. I have a geometrical model (attached .cub) where the volume block is giving me 'Element Count=0' in its properties. The model is made from intersection of sphere and brick. I am using 'cubit2specfem3d.py' script (also attached) for exporting which gives be this result:

------------------------------------------------------------------------------
CUBIT> #### Export to SESAME format using cubit2specfem3d.py of GEOCUBIT
CUBIT>
CUBIT>
CUBIT>
Turning informational messages on.
Journaled Command: set info on

Echoing has been turned ON
Journaled Command: set echo on

1 elastic 1 (1, 2, 3, 4, 5, 6, 7) HEX8 HEX8 QUAD4
2 face_topo (1, 2, 3, 4, 5, 6, 7) QUAD4 HEX8 QUAD4
3 face_abs_xmin (1, 2, 3, 4, 5, 6, 7) QUAD4 HEX8 QUAD4
4 face_abs_ymin (1, 2, 3, 4, 5, 6, 7) QUAD4 HEX8 QUAD4
5 face_abs_xmax (1, 2, 3, 4, 5, 6, 7) QUAD4 HEX8 QUAD4
6 face_abs_ymax (1, 2, 3, 4, 5, 6, 7) QUAD4 HEX8 QUAD4
7 face_abs_bottom (1, 2, 3, 4, 5, 6, 7) QUAD4 HEX8 QUAD4
Preserving undo information...done
Journaled Command: compress

Turning informational messages off.
Writing MESH/mesh_file.....
number of elements: 0
Ok
Writing MESH/materials_file.....
Ok
Writing MESH/nodes_coords_file.....
number of nodes: 1325
Ok
Writing MESH/nummaterial_velocity_file.....
#material properties:
(2, 1, 2800.0, 1500.0, 2300.0, 9000.0, 0.0)
Ok
Writing MESH/free_surface_file.....
block name: face_topo id: 2
number of faces = 0
Ok
Echoing has been turned ON
Journaled Command: set echo on

Turning informational messages off.
face_abs_xmin 3
Writing MESH/absorbing_surface_file_xmin.....
number of faces = 0
face_abs_ymin 4
Writing MESH/absorbing_surface_file_ymin.....
number of faces = 0
face_abs_xmax 5
Writing MESH/absorbing_surface_file_xmax.....
number of faces = 0
face_abs_ymax 6
Writing MESH/absorbing_surface_file_ymax.....
number of faces = 0
face_abs_bottom 7
Writing MESH/absorbing_surface_file_bottom.....
number of faces = 0
Ok
Echoing has been turned ON
Journaled Command: set echo on

Ok
Turning informational messages on.
Journaled Command: set info on

Echoing has been turned ON
Journaled Command: set echo on

CUBIT>
CUBIT> # all files needed by SCOTCH are now in directory MESH
---------------------------------------------------------------------------

I do not understand why is so many 'zeros' coming? What should I do? Thanks in advance.

Best Wishes
Khan
You do not have the required permissions to view the files attached to this post.
skusafzai
 
Posts: 2
Joined: Mon Dec 02, 2013 4:40 am

Re: Element Count = 0 for volume block

Postby csimsoft Moderator » Mon Dec 09, 2013 10:27 am

It looks like the problem is that there are no 3D hex elements; there is no volume mesh, only a surface mesh.

You could consider meshing it like this:

open 'mesh.cub'
delete mesh
vol 1 scheme sweep source surface 6 7 target surface 1
surf 7 scheme pave
mesh volume 1

Now when you export the mesh, it won't complain about zero elements in the block.
csimsoft
csimsoft Moderator
 
Posts: 247
Joined: Tue Feb 14, 2012 5:59 pm
Location: American Fork, UT


Return to Meshing

Who is online

Users browsing this forum: No registered users and 1 guest

cron

Search / Mark

User Control Panel

Login

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 58 on Mon Jun 26, 2017 4:19 pm

Users browsing this forum: No registered users and 1 guest